Click or drag to resize

GH_NamedView Constructor (Rectangle, RectangleF)

Create a new view useful for box-fit transitions.

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public GH_NamedView(
	Rectangle view_box,
	RectangleF target_box
)

Parameters

view_box
Type: System.DrawingRectangle
The dimensions of the area into which we want to display something in control coordinates. For example, the Visible area in a Viewport.
target_box
Type: System.DrawingRectangleF
The dimensions of the area we want to display in viewport coordinates. For example, the bounding box of some objects.
See Also