Click or drag to resize

GH_ViewportIsVisible Method (PointF, Single)

Test visibility of a point.

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public bool IsVisible(
	ref PointF pt,
	float margin = 0f
)

Parameters

pt
Type: System.DrawingPointF
Point in canvas coordinates.
margin (Optional)
Type: SystemSingle
Fuzzy area around point to test.

Return Value

Type: Boolean
True if the point is visible in the control upon projection.
See Also