Click or drag to resize

GH_Viewport Methods

The GH_Viewport type exposes the following members.

Methods
  NameDescription
Public methodApplyProjection
Apply the current display transformation to a Graphics object.
Public methodComputeProjection
Forces a recomputation of all cached data.
Public methodDollyZoom
Advanced interface function for mouse 'dolly' zooming.
Public methodDuplicate
Public methodFocus(IGH_Attributes)
Look at a specific object.
Public methodFocus(ListIGH_Attributes)
Look at a set of specific objects.
Public methodFocus(Point)
Look at a specific point.
Public methodFocus(PointF)
Look at a specific point.
Public methodIsVisible(PointF, Single)
Test visibility of a point.
Public methodIsVisible(RectangleF, Single)
Test visibility of a rectangle.
Public methodLimitUnit
Utility function for calculating pixel dimensions in a zoom-aware environment. The desired value is put through the zoom projection and if the resulting size (as displayed on the screen) exceeds the visual limits it is clipped. This function can be used for example to make sure that a certain penwidth never exceeds visual limits (i.e. it doesn't get too thin or too thick on the screen).
Public methodProject
Transform a point from canvas into control coordinate space.
Public methodProjectPoint
Project a point from canvas coordinates into control coordinates.
Public methodProjectRectangle
Project a rectangle from canvas coordinates into control coordinates.
Public methodProjectX
Project a value along constant X from canvas coordinates into control coordinates.
Public methodProjectY
Project a value along constant Y from canvas coordinates into control coordinates.
Public methodSet
Public methodSolveUnit
Utility function for calculating graphics dimensions in a zoom-aware environment. This function can be used for example to compute the linewidth of a pen which always needs to appear as 3 pixels thick on the screen regardless of zoom values.
Public methodUnproject
Transform a point from control into canvas coordinate space.
Public methodUnprojectPoint
Project a point from control coordinates into canvas coordinates.
Public methodUnprojectRectangle
Project a rectangle from control coordinates into canvas coordinates.
Public methodUnprojectX
Project a value along constant X from control coordinates into canvas coordinates.
Public methodUnprojectY
Project a value along constant Y from control coordinates into canvas coordinates.
Public methodXFormMatrix
Gets the display transformation cached by this viewport.
Top
See Also