Click or drag to resize

GH_CanvasMouseEvent Constructor (Point, PointF, MouseButtons, Int32, Int32)

Constructor.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public GH_CanvasMouseEvent(
	Point pt_control,
	PointF pt_canvas,
	MouseButtons mButton,
	int iClicks = 0,
	int iDelta = 0
)

Parameters

pt_control
Type: System.DrawingPoint
Cursor location in control pixel coordinates.
pt_canvas
Type: System.DrawingPointF
Cursor location in canvas unit coordinates.
mButton
Type: System.Windows.FormsMouseButtons
Currently pressed mouse buttons.
iClicks (Optional)
Type: SystemInt32
Number of times the buttons were pressed and released.
iDelta (Optional)
Type: SystemInt32
A signed count of the number of detents the mouse wheel has rotated.
See Also