Click or drag to resize

GH_CanvasMouseEvent Class

Class used in Canvas UI events.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Grasshopper.GUIGH_CanvasMouseEvent

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_CanvasMouseEvent : EventArgs

The GH_CanvasMouseEvent type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyButton
Gets which mouse button was pressed.
Public propertyCanvasLocation
Gets the location of the cursor in canvas unit coordinates.
Public propertyCanvasX
Gets the x-coordinate of the cursor location in canvas unit coordinates.
Public propertyCanvasY
Gets the y-coordinate of the cursor location in canvas unit coordinates.
Public propertyClicks
Gets the number of times the mouse button was pressed and released.
Public propertyControlLocation
Gets the location of the cursor in control pixel coordinates.
Public propertyControlX
Gets the x-coordinate of the cursor location in control pixel coordinates.
Public propertyControlY
Gets the y-coordinate of the cursor location in control pixel coordinates.
Public propertyDelta
Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel.
Public propertyWinFormsEventArgs
Downcast this data into a Windows.Forms.MouseEventArgs instance.
Top
See Also