Click or drag to resize

GH_ComponentAttributesRenderComponentCapsule Method (GH_Canvas, Graphics)

Utility function, draws the complete component capsule including all parameter data.

Namespace:  Grasshopper.Kernel.Attributes
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
protected void RenderComponentCapsule(
	GH_Canvas canvas,
	Graphics graphics
)

Parameters

canvas
Type: Grasshopper.GUI.CanvasGH_Canvas
Canvas to draw into.
graphics
Type: System.DrawingGraphics
Graphics object to draw with.
See Also