Click or drag to resize

GH_ComponentAttributes Methods

The GH_ComponentAttributes type exposes the following members.

Methods
  NameDescription
Public methodAppendToAttributeTree (Overrides GH_AttributesTAppendToAttributeTree(ListIGH_Attributes).)
Public methodExpireLayout (Overrides GH_AttributesTExpireLayout.)
Public methodInvalidateCanvas
The canvas must be invalidated when the mouse is near enough and this component has variable parameters.
(Overrides GH_AttributesTInvalidateCanvas(GH_Canvas, GH_CanvasMouseEvent).)
Public methodIsPickRegion(PointF) (Overrides GH_AttributesTIsPickRegion(PointF).)
Protected methodLayout (Overrides GH_AttributesTLayout.)
Public methodStatic memberLayoutBounds
Public methodStatic memberLayoutComponentBox
Utility layout method for GH_Component style UI.
Public methodStatic memberLayoutInputParams
Public methodStatic memberLayoutOutputParams
Protected methodRender (Overrides GH_AttributesTRender(GH_Canvas, Graphics, GH_CanvasChannel).)
Protected methodRenderComponentCapsule(GH_Canvas, Graphics)
Utility function, draws the complete component capsule including all parameter data.
Protected methodRenderComponentCapsule(GH_Canvas, Graphics, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
Utility function, draws the component capsule including all specified elements.
Public methodStatic memberRenderComponentParameters
Utility method for rendering all component parameters.
Protected methodRenderVariableParameterUI
Public methodRespondToMouseDown (Overrides GH_AttributesTRespondToMouseDown(GH_Canvas, GH_CanvasMouseEvent).)
Public methodSetupTooltip (Overrides GH_AttributesTSetupTooltip(PointF, GH_TooltipDisplayEventArgs).)
Top
See Also