Click or drag to resize

GH_ComponentAttributes Class

These Attributes are the default for GH_Components.
Inheritance Hierarchy
System.Object
  Grasshopper.Kernel.GH_Attributes<IGH_Component>
    Grasshopper.Kernel.Attributes.GH_ComponentAttributes

Namespace:  Grasshopper.Kernel.Attributes
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_ComponentAttributes : GH_Attributes<IGH_Component>

The GH_ComponentAttributes type exposes the following members.

Constructors
  NameDescription
Public methodGH_ComponentAttributes
Initializes a new instance of the GH_ComponentAttributes class
Top
Properties
  NameDescription
Public propertyContentBox
Gets the bounds of the component area of the attributes.
Public propertyHasInputGrip (Overrides GH_Attributes<T>.HasInputGrip.)
Public propertyHasOutputGrip (Overrides GH_Attributes<T>.HasOutputGrip.)
Public propertyPathName (Overrides GH_Attributes<T>.PathName.)
Top
Methods
  NameDescription
Public methodAppendToAttributeTree (Overrides GH_Attributes<T>.AppendToAttributeTree(List<IGH_Attributes>).)
Public methodExpireLayout (Overrides GH_Attributes<T>.ExpireLayout().)
Public methodInvalidateCanvas
The canvas must be invalidated when the mouse is near enough and this component has variable parameters.
(Overrides GH_Attributes<T>.InvalidateCanvas(GH_Canvas, GH_CanvasMouseEvent).)
Public methodIsPickRegion(PointF) (Overrides GH_Attributes<T>.IsPickRegion(PointF).)
Protected methodLayout (Overrides GH_Attributes<T>.Layout().)
Public methodStatic memberLayoutBounds
Public methodStatic memberLayoutComponentBox
Utility layout method for GH_Component style UI.
Public methodStatic memberLayoutInputParams
Public methodStatic memberLayoutOutputParams
Protected methodRender (Overrides GH_Attributes<T>.Render(GH_Canvas, Graphics, GH_CanvasChannel).)
Protected methodRenderComponentCapsule(GH_Canvas, Graphics)
Utility function, draws the complete component capsule including all parameter data.
Protected methodRenderComponentCapsule(GH_Canvas, Graphics, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
Utility function, draws the component capsule including all specified elements.
Public methodStatic memberRenderComponentParameters
Utility method for rendering all component parameters.
Protected methodRenderVariableParameterUI
Public methodRespondToMouseDown (Overrides GH_Attributes<T>.RespondToMouseDown(GH_Canvas, GH_CanvasMouseEvent).)
Public methodSetupTooltip (Overrides GH_Attributes<T>.SetupTooltip(PointF, GH_TooltipDisplayEventArgs).)
Top
Fields
  NameDescription
Protected fieldm_innerBounds
Represents the Rectangle that contains the component black box.
Top
See Also