Click or drag to resize

GH_LexerEvaluatePath Method

Evaluate the variables in this mask with the provided expression solver.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public bool EvaluatePath(
	GH_ExpressionParser evaluator,
	ref GH_Path path,
	ref int index
)

Parameters

evaluator
Type: Grasshopper.Kernel.ExpressionsGH_ExpressionParser
Evaluator to use. Must have all variables properly set up.
path
Type: Grasshopper.Kernel.DataGH_Path
Path result.
index
Type: SystemInt32
Index result. If the lexer contains no item representation then the index remains unmolested.

Return Value

Type: Boolean
True on success, false on failure.
See Also