Click or drag to resize

GH_Lexer Class

Represents a lexical mask for path operations.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.DataGH_Lexer

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Lexer

The GH_Lexer type exposes the following members.

Constructors
  NameDescription
Public methodGH_Lexer
Blank constructor.
Public methodGH_Lexer(String)
Create a new mask from a textual string.
Top
Properties
  NameDescription
Public propertyIsItem
Gets a value indicating whether or not the item portion of the lexer has been set.
Public propertyIsPath
Gets a value indicating whether or not the path portion of the lexer has been set.
Public propertyItem
Gets the item string that was extracted from the mask. The default is "append"
Public propertyMask
Gets the original string that represents the user input for this lexer.
Public propertyPath
Gets the list of path strings that was extracted from the mask. If the mask hasn't been parsed yet, it will be parsed now. If the returned list is still nothing, parsing failed.
Top
Methods
See Also