Click or drag to resize

GH_LexerPerformLexicalReplaceT Method (GH_Lexer, GH_Lexer, IGH_Structure, GH_StructureT)

Lexical Find..Replace operations.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void PerformLexicalReplace<T>(
	GH_Lexer source,
	GH_Lexer target,
	IGH_Structure structure_in,
	GH_Structure<T> structure_out
)
where T : IGH_Goo

Parameters

source
Type: Grasshopper.Kernel.DataGH_Lexer
Search mask.
target
Type: Grasshopper.Kernel.DataGH_Lexer
Replace pattern.
structure_in
Type: Grasshopper.Kernel.DataIGH_Structure
Source data tree.
structure_out
Type: Grasshopper.Kernel.DataGH_StructureT
Target data tree.

Type Parameters

T
Type of data in target tree.
See Also