Click or drag to resize

IGH_StructureGraft Method (GH_GraftMode, GH_Path)

Grafts a specific path by reallocating all data into child paths. If a grafted path coincides with an existing path, the data item in question will be appended to the existing path.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
void Graft(
	GH_GraftMode mode,
	GH_Path path
)

Parameters

mode
Type: Grasshopper.Kernel.DataGH_GraftMode
Graft mode.
path
Type: Grasshopper.Kernel.DataGH_Path
Path to graft
See Also