Click or drag to resize

IGH_Structure Methods

The IGH_Structure type exposes the following members.

Methods
  NameDescription
Public methodAllData
Gets an enumerator for all the data items in this structure.
Public methodClear
Clears the entire structure.
Public methodClearData
Removes all data from all paths without affecting the structure topology.
Public methodDataDescription
Gets a description of the data contained in this structure.
Public methodEnsureCapacity
Ensures that all branches have a certain capacity
Public methodExpandPath
Expand a path in this structure by appending an element.
Public methodFlatten
Flattens the entire structure into a single path.
Public methodGraft(GH_GraftMode)
Grafts all paths by reallocating all data into child paths.
Public methodGraft(GH_GraftMode, GH_Path)
Grafts a specific path by reallocating all data into child paths. If a grafted path coincides with an existing path, the data item in question will be appended to the existing path.
Public methodLongestPathIndex
Finds the path in this structure with the most dimensions. In case of multiple equally long longest paths, the last one will be returned.
Public methodPathExists
Returns True if the specified path is already defined inside the structure.
Public methodPathIndex
Find the indices that delineate the given path domain.
Public methodRemovePath
Removes a path and all associated data from the structure. If the path doesn't exist, nothing will happen.
Public methodReplacePath
Replace an existing path with a different one. If the operation is successfull, then the 'find' path will be deleted. If the 'replace' path is already defined, the items in 'find' will be appended to the existing path.
Public methodShortestPathIndex
Finds the path in this structure with the least dimensions. In case of multiple equally long longest paths, the first one will be returned.
Public methodSimplify
Simplify the data structure by removing path indices shared by all branches.
Public methodTrimExcess
Trims the excess allocated memory in all branches
Top
See Also