Click or drag to resize

GH_DocumentIOSubsidiaryDocumentSavePrompt Method (String, Boolean, Int32)

Display a 'stuff has changed do you want to save' message box with Yes/No/Cancel options.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static DialogResult SubsidiaryDocumentSavePrompt(
	string documentName,
	bool modified,
	int modifiedSubsidiaries
)

Parameters

documentName
Type: SystemString
Name of top level document.
modified
Type: SystemBoolean
Boolean indicating whether top-level document is modified.
modifiedSubsidiaries
Type: SystemInt32
Number of modified subsidiary documents.

Return Value

Type: DialogResult
Yes, No, Cancel or None state.
See Also