GH_DocumentObjectGetValue Method (String, Int32) |
Get an integer value from the component value table.
Namespace:
Grasshopper.Kernel
Assembly:
Grasshopper (in Grasshopper.dll)
Syntax protected int GetValue(
string valueName,
int default
)
Protected Function GetValue (
valueName As String,
default As Integer
) As Integer
Parameters
- valueName
- Type: SystemString
Name of integer to retrieve. - default
- Type: SystemInt32
Default value to return in case of missing named value.
Return Value
Type:
Int32The integer value with the given name of the default value.
See Also