Click or drag to resize

GH_DocumentObject Class

Standard implementation of IGH_DocumentObject.
Inheritance Hierarchy

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class GH_DocumentObject : GH_InstanceDescription, 
	IGH_DocumentObject

The GH_DocumentObject type exposes the following members.

Constructors
  NameDescription
Protected methodGH_DocumentObject(IGH_InstanceDescription)
Initializes a new instance of the GH_DocumentObject class
Protected methodGH_DocumentObject(String, String, String, String, String)
Initializes a new instance of the GH_DocumentObject class
Top
Properties
  NameDescription
Public propertyAttributes
Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing.
Public propertyComponentGuid
Returns a consistent ID for this object type. Every object must supply a unique and unchanging ID that is used to identify objects of the same type.
Public propertyExposure
Gets the exposure of this object in the Graphical User Interface. The default is to expose everywhere.
Protected propertyIcon
Override this function to supply a custom icon (24x24 pixels). The result of this property is cached, so don't worry if icon retrieval is not very fast.
Public propertyIcon_24x24
The icon associated with this object.
Public propertyIcon_24x24_Locked
The greyscale icon of this object.
Public propertyIconDisplayMode
Gets the current display mode of the object.
Public propertyObsolete
Gets whether this object is obsolete. Default implementation returns true if the class name contains the string "OBSOLETE" or if this class has been decorated with the ObsoleteAttribute. You are free to override this if you want, but I suggest adding the ObsoleteAttribute instead.
Top
Methods
  NameDescription
Public methodAddedToDocument
This method will be called when an object is added to a document. Override this method if you want to handle such events.
Public methodAppendMenuItems
This function is called when a context menu is about to be displayed. Override it to set custom items.
Public methodCreateAttributes
This function creates the stand-alone attributes for this object. If you wish to supply your own Attributes, you must override this function.
Protected methodDestroyIconCache
Call this method to erase the existing icon cache. You must call this if you want to change the display icon of an object.
Public methodDocumentContextChanged
This method will be called when the document that owns this object moves into a different context.
Public methodExpirePreview
Call this function when you suspect that the preview has expired for this object. This will cause the display cache to be eradicated.
Public methodExpireSolution
Call this function whenever you do something which expires the current solution. This will make sure all caches are erased, all downstream objects are expired and that the event is raised. The default implementation merely places a call to OnSolutionExpired(), override this function in derived classes to make sure you clear local data caches and expire downstream objects.
Protected methodGetValue(String, Boolean)
Get a boolean value from the component value table.
Protected methodGetValue(String, Double)
Get a double value from the component value table.
Protected methodGetValue(String, Color)
Get a color value from the component value table.
Protected methodGetValue(String, Int32)
Get an integer value from the component value table.
Protected methodGetValue(String, String)
Get a string value from the component value table.
Protected methodHtmlHelp_Source
Return a String which contains HTML formatted source for the help topic. If you want to pass a URL that points to a remote page, then prefix the URL with a GOTO: tag, like so: GOTO:http://www.YourWebAddressHere.com
Public methodIsolateObject
Destroy all connections to other objects.
Public methodStatic memberMenu_AppendColourPicker
Add a colour picker to a menu.
Public methodStatic memberMenu_AppendCustomItem(ToolStripDropDown, Control)
Utility function for inserting exotic controls into dropdown menus.
Public methodStatic memberMenu_AppendCustomItem(ToolStripDropDown, Control, KeyDownEventHandler)
Utility function for inserting exotic controls into dropdown menus.
Public methodStatic memberMenu_AppendCustomItem(ToolStripDropDown, Control, KeyDownEventHandler, Boolean, Int32, Boolean)
Utility function for inserting exotic controls into dropdown menus.
Public methodStatic memberMenu_AppendDigitScrollerItem
Utility function for inserting a digit scroller into menus.
Public methodStatic memberMenu_AppendItem(ToolStrip, String)
Utility function for appending generic menu items.
Public methodStatic memberMenu_AppendItem(ToolStrip, String, EventHandler)
Utility function for appending generic menu items.
Public methodStatic memberMenu_AppendItem(ToolStrip, String, EventHandler, Boolean)
Utility function for appending generic menu items.
Public methodStatic memberMenu_AppendItem(ToolStrip, String, EventHandler, Image)
Utility function for appending generic menu items.
Public methodStatic memberMenu_AppendItem(ToolStrip, String, EventHandler, Boolean, Boolean)
Utility function for appending generic menu items.
Public methodStatic memberMenu_AppendItem(ToolStrip, String, EventHandler, Image, Object)
Utility function for appending generic menu items.
Public methodStatic memberMenu_AppendItem(ToolStrip, String, EventHandler, Image, Boolean, Boolean)
Utility function for appending generic menu items.
Protected methodMenu_AppendObjectHelp
Appends the default object Help menu item.
Protected methodMenu_AppendObjectName
Appends the old-fashioned object name menu item. If you also want the Display mode toggle then use Menu_AppendObjectNameEx()
Protected methodMenu_AppendObjectNameEx
Appends the default object name + display mode menu item.
Protected methodMenu_AppendPublish
Appends the default item for publishing to RCP. This menu will only appear if the current class implement IRcpAwareObject
Public methodStatic memberMenu_AppendSeparator
Utility function for appending separators to a menu dropdown. If the dropdown is empty or if it already has a separator at the bottom, nothing will happen.
Public methodStatic memberMenu_AppendTextItem(ToolStripDropDown, String, GH_MenuTextBoxKeyDownEventHandler, GH_MenuTextBoxTextChangedEventHandler, Boolean)
Utility function for inserting text boxes into menus.
Public methodStatic memberMenu_AppendTextItem(ToolStripDropDown, String, GH_MenuTextBoxKeyDownEventHandler, GH_MenuTextBoxTextChangedEventHandler, Boolean, Int32, Boolean)
Utility function for inserting text boxes into menus.
Public methodStatic memberMenu_MoveItem(ToolStripItem, String)
Utility function for moving menu items.
Public methodStatic memberMenu_MoveItem(ToolStripItem, Boolean, String)
Utility function for moving menu items.
Public methodMovedBetweenDocuments
This method will be called when an object is moved from one document to another. Override this method if you want to handle such events.
Public methodOnAttributesChanged
Raises the AttributesChanged event on the toplevel object.
Public methodOnDisplayExpired
Raises the DisplayExpired event on the toplevel object.
Public methodOnObjectChanged(GH_ObjectChangedEventArgs)
Public methodOnObjectChanged(GH_ObjectEventType)
Public methodOnObjectChanged(String)
Public methodOnObjectChanged(GH_ObjectEventType, Object)
Public methodOnObjectChanged(String, Object)
Public methodOnPingDocument
Raise the PingDocument Event on the toplevel object and try to find the document which owns this object.
Public methodOnPreviewExpired
Raises the PreviewExpired event on the toplevel object.
Public methodOnSolutionExpired
Raises the SolutionExpired event on the toplevel object. You probably want to call ExpireSolution() instead of this method directly.
Public methodRead (Overrides GH_InstanceDescriptionRead(GH_IReader).)
Public methodRecordUndoEvent(GH_UndoRecord)
Record an entire undo record.
Public methodRecordUndoEvent(String)
Record a generic object change undo event.
Public methodRecordUndoEvent(String, IGH_UndoAction)
Record a specific object change undo event.
Public methodRemovedFromDocument
This method will be called when an object is removed from a document. Override this method if you want to handle such events.
Public methodSetIconOverride
Set a new custom icon override for this object.
Protected methodSetValue(String, Boolean)
Set a named value. This value will be serialized with the component.
Protected methodSetValue(String, Double)
Set a named value. This value will be serialized with the component.
Protected methodSetValue(String, Color)
Set a named value. This value will be serialized with the component.
Protected methodSetValue(String, Int32)
Set a named value. This value will be serialized with the component.
Protected methodSetValue(String, String)
Set a named value. This value will be serialized with the component.
Public methodTriggerAutoSave
Triggers the AutoSave function on the owner document with the object_changed flag.
Public methodTriggerAutoSave(GH_AutoSaveTrigger)
Triggers the AutoSave function on the owner document with a custom flag.
Public methodTriggerAutoSave(Guid)
Triggers the AutoSave function on the owner document with the object_changed flag.
Public methodTriggerAutoSave(GH_AutoSaveTrigger, Guid)
Triggers the AutoSave function on the owner document with a custom flag.
Protected methodValuesChanged
Override this method if you want to respond to changes to the value table. The base implementation is empty, so you don't have to call it.
Public methodWrite (Overrides GH_InstanceDescriptionWrite(GH_IWriter).)
Top
Events
  NameDescription
Public eventAttributesChanged
Raised whenever the number or kind of attributes changes. This event is handled by GH_Documents who subsequently wipe their attribute caches.
Public eventDisplayExpired
Raised whenever the display (on the Canvas) of a certain object becomes invalid.
Public eventObjectChanged
Public eventPingDocument
Raised whenever an object needs to know which GH_Document it belongs to.
Public eventPreviewExpired
Raised whenever the display (in the Rhino viewports) of a certain object becomes invalid.
Public eventSolutionExpired
Raised whenever the solution of a certain object becomes invalid.
Top
Fields
  NameDescription
Protected fieldm_attributes
Top
See Also