Click or drag to resize

GH_DocumentServerAddDocument Method (GH_Document)

Add a new document to the global list. If the document is already registered nothing will happen.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public void AddDocument(
	GH_Document document
)

Parameters

document
Type: Grasshopper.KernelGH_Document
Document to add.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when the document is a null reference.
InvalidOperationExceptionThrown when the document doesn't have top-level rank.
See Also