Click or drag to resize

GH_DocumentRelevantObjectAtPoint Method (PointF)

Find the most relevant object at a given canvas location. The most relevant object might be a regular Object (Component or Parameter), it might be an attribute grip, an attribute balloon, a wire or a group.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public GH_RelevantObjectData RelevantObjectAtPoint(
	PointF pt
)

Parameters

pt
Type: System.DrawingPointF
The point to test.

Return Value

Type: GH_RelevantObjectData
Information about the most relevant object or Null if no relevant object could be found at the given point.
See Also