Click or drag to resize

GH_DocumentRemoveObject Method (IGH_DocumentObject, Boolean)

Remove the object from the document. This removal is the precursor to object deletion. Do not call this function if you intend to transfer the object to another GH_Document. This method does not add an Undo event, that is the responsibility of the caller.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public bool RemoveObject(
	IGH_DocumentObject docObject,
	bool update
)

Parameters

docObject
Type: Grasshopper.KernelIGH_DocumentObject
Object to remove.
update
Type: SystemBoolean

Return Value

Type: Boolean
See Also