Click or drag to resize

GH_Document.Write Method (GH_IWriter, IList<IGH_DocumentObject>)

Special function that allows writing of a custom object list. This function is used when partial documents need to be serialized such as when exporting or during clipboard operations.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public bool Write(
	GH_IWriter writer,
	IList<IGH_DocumentObject> objList
)

Parameters

writer
Type: GH_IO.Serialization.GH_IWriter
Writer to serialize with.
objList
Type: System.Collections.Generic.IList<IGH_DocumentObject>
Object list override

Return Value

Type: Boolean
See Also