Click or drag to resize

IGH_DataAccessGetDataTreeT Method (String, GH_StructureT)

Retrieve an entire data tree from an input parameter during GH_Component.SolveInstance().

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
bool GetDataTree<T>(
	string name,
	out GH_Structure<T> tree
)
where T : IGH_Goo

Parameters

name
Type: SystemString
tree
Type: Grasshopper.Kernel.DataGH_StructureT

Type Parameters

T
Type of the data to retrieve. Must be identical to the type stored in the parameter.

Return Value

Type: Boolean
True on success, false on failure.
Remarks
Parameter access by index is faster, consider using the other overload if possible.
See Also