Click or drag to resize

IGH_DataAccess Interface

Provides access to component parameters, in order to retrieve and assign data during solutions.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_DataAccess

The IGH_DataAccess type exposes the following members.

Properties
  NameDescription
Public propertyIteration
Gets the current iteration count. The first time the SolveInstance() function is called on a component during a solution the Iteration counter will be zero. It will be incremented by one for every subsequent call.
Top
Methods
  NameDescription
Public methodAbortComponentSolution
Call this method if you wish to stop solving this component.
Public methodBlitDataQ
Creates a direct copy of an existing data structure. The existing generic instance must of the exact same type as the target parameter.
Public methodDisableGapLogic
Call this function if you want to disable the gap null logic for the current iteration.
Public methodDisableGapLogic(Int32)
Call this function if you want to disable the gap null logic for a specific output parameter.
Public methodGetDataT(Int32, T)
Retrieve data from an input parameter during GH_Component.SolveInstance().
Public methodGetDataT(String, T)
Retrieve data from an input parameter during GH_Component.SolveInstance().
Public methodGetDataListT(Int32, ListT)
Retrieve an entire list of data from an input parameter during GH_Component.SolveInstance().
Public methodGetDataListT(String, ListT)
Retrieve an entire list of data from an input parameter during GH_Component.SolveInstance().
Public methodGetDataTreeT(Int32, GH_StructureT)
Retrieve an entire data tree from an input parameter during GH_Component.SolveInstance().
Public methodGetDataTreeT(String, GH_StructureT)
Retrieve an entire data tree from an input parameter during GH_Component.SolveInstance().
Public methodIncrementIteration
Increments the iteration count by 1.
Public methodParameterTargetIndex
Get the target index for the specified output parameter.
Public methodParameterTargetPath
Get the target path for the specified output parameter.
Public methodSetData(Int32, Object)
Stores data in an output parameter during GH_Component.SolveInstance(). Use this function only for setting individual data items. If you want to set lists of data, you *must* call SetDataList() instead.
Public methodSetData(String, Object)
Stores data in an output parameter during GH_Component.SolveInstance().
Public methodSetData(Int32, Object, Int32)
Expert user function. Stores data in an output parameter during GH_Component.SolveInstance(). Use this function only for setting individual data items. If you want to set lists of data, you *must* call SetDataList() instead.
Public methodSetDataList(Int32, IEnumerable)
Stores a list of data in an output parameter during GH_Component.SolveInstance().
Public methodSetDataList(String, IEnumerable)
Stores data in an output parameter during GH_Component.SolveInstance().
Public methodSetDataList(Int32, IEnumerable, Int32)
Expert user function. Stores a list of data in an output parameter during GH_Component.SolveInstance().
Public methodSetDataTree(Int32, IGH_DataTree)
Folds a utility tree representation into this tree.
Public methodSetDataTree(Int32, IGH_Structure)
Folds a utility tree representation into this tree.
Public methodUtil_CountNonNullRefsT
Count all object references in L
Public methodUtil_CountNullRefsT
Count all null references in L
Public methodUtil_EnsureNonNullCountT
Tests a list to see if it contains sufficient non-null references.
Public methodUtil_FirstNonNullItemT
Returns the index of the first non-null item in a list.
Public methodUtil_RemoveNullRefsT
Remove all null references from a list of items.
Top
See Also