Click or drag to resize

IGH_DataAccessGetDataT Method (String, T)

Retrieve data from an input parameter during GH_Component.SolveInstance().

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
bool GetData<T>(
	string name,
	ref T destination
)

Parameters

name
Type: SystemString
destination
Type: T

Type Parameters

T
Type of the data to retrieve. If the data type does not match the parameter type, a conversion will be attempted.

Return Value

Type: Boolean
True on success, false on failure.
Remarks
Parameter access by index is faster, consider using the other overload if possible.
See Also