Click or drag to resize

IGH_DataAccessSetDataList Method (Int32, IEnumerable)

Stores a list of data in an output parameter during GH_Component.SolveInstance().

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
bool SetDataList(
	int paramIndex,
	IEnumerable data
)

Parameters

paramIndex
Type: SystemInt32
Index of the output parameter at which to store the list.
data
Type: System.CollectionsIEnumerable
Data to store. Data will be converted if necessary, but it will not be duplicated automatically.

Return Value

Type: Boolean
See Also