Click or drag to resize

IGH_DataAccessSetData Method (String, Object)

Stores data in an output parameter during GH_Component.SolveInstance().

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
bool SetData(
	string paramName,
	Object data
)

Parameters

paramName
Type: SystemString
Name of the output parameter at which to store the data.
data
Type: SystemObject
Data to store. Data will be converted if necessary, but it will not be duplicated automatically.

Return Value

Type: Boolean
Remarks
Parameter access by index is faster, consider using the other overload if possible.
See Also