Click or drag to resize

GH_PointUtilPullPointsToPlane Method

Pull a list of points onto the plane. The result will be points in 3D world coordinates which are coincident with the given plane.

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static List<GH_Point> PullPointsToPlane(
	IEnumerable<GH_Point> pts,
	Plane plane,
	bool include_nulls
)

Parameters

pts
Type: System.Collections.GenericIEnumerableGH_Point
Points to pull.
plane
Type: Plane
Plane to pull onto.
include_nulls
Type: SystemBoolean
If True, nulls in the pts list are maintained.

Return Value

Type: ListGH_Point
See Also