Click or drag to resize

GH_Variant Methods

The GH_Variant type exposes the following members.

Methods
  NameDescription
Public methodDataT
Perform a straight cast of the data inside this Variant.
Public methodDuplicate
Duplicate this Variant. If the type of this Variant is [unknown] the contents are not guaranteed to be duplicated.
Public methodEvaluate
If this variant represents a string, this function will attempt to evaluate that string and replace the data inside this variant.
Public methodToGoo
Attempt to convert a Variant to a Grasshopper IGH_Goo type.
Public methodToString (Overrides ObjectToString.)
Top
See Also