Click or drag to resize

GH_GooT Methods

The GH_GooT generic type exposes the following members.

Methods
  NameDescription
Public methodCastFrom
Attempt a cast from generic data.
Public methodCastToQ
Attempt a cast to type Q.
Public methodDuplicate
Make a complete duplicate of this instance. No shallow copies.
Public methodEmitProxy
Create a new proxy for this instance. Return Null if this class does not support proxies.
Public methodRead
Default behaviour is to return True.
Public methodScriptVariable
This function will be called when the local IGH_Goo instance disappears into a user Script. This would be an excellent place to cast your IGH_Goo type to a simple data type.
Public methodToString
Creates a string description of the current instance value.
(Overrides ObjectToString.)
Public methodWrite
Default behaviour is to return True.
Top
See Also