Click or drag to resize

GH_StructureTDataItem Property (GH_Path, Int32)

Gets a direct pointer to a data item under a specific path and index.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public T this[
	GH_Path path,
	int index
] { get; }

Parameters

path
Type: Grasshopper.Kernel.DataGH_Path
Path of the data branch to retrieve.
index
Type: SystemInt32
Index of item to retrieve.

Property Value

Type: T

[Missing <value> documentation for "P:Grasshopper.Kernel.Data.GH_Structure`1.DataItem(Grasshopper.Kernel.Data.GH_Path,System.Int32)"]

Exceptions
ExceptionCondition
NullReferenceExceptionThrown if the path doesn't exist.
IndexOutOfRangeExceptionThrown if the index does not exist within the path list.
See Also