Click or drag to resize

GH_StructureT Properties

The GH_StructureT generic type exposes the following members.

Properties
  NameDescription
Public propertyBranchGH_Path
Gets a limited access pointer to the data list associated with a certain path.
Public propertyBranchInt32
Gets a limited access pointer to the data list at the specified index
Public propertyBranches
Gets a list of all the data-arrays in this structure
Public propertyDataCount
Gets the total number of data items stored in all paths.
Public propertyDataItemInt32
Gets the item at a given offset. The structure is treated as a linear list in this case. If index is out of range, null is returned. For repeated indexed retrieval, consider using a For Each loop since the enumerator is more efficient.
Public propertyDataItemGH_Path, Int32
Gets a direct pointer to a data item under a specific path and index.
Public propertyDataListGH_Path
Gets a direct pointer to the list of data under a specific path.
Public propertyDataListInt32
Gets a direct pointer to the list of data under the specified index.
Public propertyFirstItem
Gets the first item in the structure. If no such item exists, null is returned.
Public propertyIsEmpty
Gets the Empty state of the structure. If the structure is Empty it contains no paths and no branches.
Public propertyLastItem
Gets the last item in the structure. If no such item exists, null is returned.
Public propertyNonNulls
Get an enumerator for this structure that allow linear iteration over the data hierarchy while skipping all Null entries. This Enumerator has been optimized, do not cache instances of it.
Public propertyPath
Gets the data path at the specified index.
Public propertyPathCount
Gets the number of paths defined in this structure.
Public propertyPaths
Gets a list of all the paths in this structure.
Public propertyStructureProxy
Gets a proxy list of all the data-arrays in this structure.
Public propertyTopologyDescription
Gets a description of the topology of the structure. Useful for debugging purposes.
Top
See Also