Click or drag to resize

GH_Chunk Properties

The GH_Chunk type exposes the following members.

Properties
  NameDescription
Public propertyArchive
Gets a pointer to the archive that owns the Root of the tree this chunk belongs to.
Public propertyArchiveLocation
Gets a string representing the URI with which the archive is associated. The location may be a null string.
Public propertyChunkCount
Gets the number of child chunks contained in this chunk. The set of all child chunks is referred to as a 'litter'.
Public propertyChunks
Gets a pointer to the internal list of child chunks. Do not access this list unless you know what you are doing.
Public propertyHasComments
Gets a value that indicates whether or not comments have been stored in this chunk.
Public propertyHasIndex
Gets the index existence implication. The item is considered to have an index qualifier if the index value is larger than or equal to zero.
Public propertyHasName
Gets the name validity of this item. The item is considered to have an invalid name if string.IsNullOrEmpty(name)
Public propertyIndex
Gets the index of this chunk. The index is set by the owner of this chunk. Indices smaller than zero imply no index has been set. The combination of name+index is always unique among a set of chunks in the same litter.
Public propertyItemCount
Gets the number of items contained in this chunk.
Public propertyItems
Gets a pointer to the internal list of items. Do not access this list unless you know what you are doing.
Public propertyName
Gets the name of this chunk. The name is set by the owner of this chunk. Names must be at least 1 character long. The combination of name+index is always unique among a set of chunks in a single litter.
Top
See Also