Click or drag to resize

CentralSettings Properties

The CentralSettings type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberAuthorAddress
Gets or sets the default author address to be used for all data generated by this Grasshopper installation.
Public propertyStatic memberAuthorCompany
Gets or sets the default author company to be used for all data generated by this Grasshopper installation.
Public propertyStatic memberAuthorCopyright
Gets or sets the default author copyright to be used for all data generated by this Grasshopper installation.
Public propertyStatic memberAuthorCopyrightFormatted
Gets the authorCopyright message formatted to match the current date.
Public propertyStatic memberAuthorDetails
Gets a new GH_AuthorDetails instance populated with the current settings. Changing this instance does not affect the settings.
Public propertyStatic memberAuthorEMail
Gets or sets the default author e-mail to be used for all data generated by this Grasshopper installation.
Public propertyStatic memberAuthorName
Gets or sets the default author name to be used for all data generated by this Grasshopper installation.
Public propertyStatic memberAuthorPhone
Gets or sets the default author phone to be used for all data generated by this Grasshopper installation.
Public propertyStatic memberAuthorWebsite
Gets or sets the default author website to be used for all data generated by this Grasshopper installation.
Public propertyStatic memberCanvasFancyWires
Gets or sets whether or not fancy wires will be drawn. This is a global setting.
Public propertyStatic memberCanvasFullNames
Gets or sets the global default for verbose UI. When CanvasFullNames=True, parameter nicknames are set to their actual (long) names upon addition.
Public propertyStatic memberCanvasMaxSearchResults
Gets or sets the maximum number of search results for populating the Create menu.
Public propertyStatic memberCanvasObjectIcons
Gets or sets the global default for icon display.
Public propertyStatic memberCanvasObsoleteTags
Gets or sets the global default for obsolete tags.
Public propertyStatic memberCanvasRadialMenu
Gets or sets the global default for whether the canvas should use Radial or olds-kool menus.
Public propertyStatic memberCanvasSpaceIsRadialMenu
Gets or sets whether the space bar triggers the radial menu (pre Rhino 6.3 behaviour) or the Create menu (post Rhino 6.3 behaviour).
Public propertyStatic memberCanvasSpaceSearchRadialMessage
Gets or sets the number of times the space-is-now-search-and-not-radial message has been shown.
Public propertyStatic memberCanvasToolbar
Gets or sets whether or not the canvas toolbar will be visible. This is a global setting.
Public propertyStatic memberCanvasZuiZoomLevel
Gets or sets the global Zui zoom threshold.
Public propertyStatic memberComponentCascadeMenus
Gets or sets whether Grasshopper document solutions are wrapped in undo records.
Public propertyStatic memberCreateSolutionUndoRecord
Gets or sets whether Grasshopper document solutions are wrapped in undo records.
Public propertyStatic memberFormatDecimalDigits
Gets or sets how many digits ought to be used for decimal formatted numbers.
Public propertyStatic memberFormatENotationDigits
Gets or sets how many digits ought to be used for scientific notation formatted numbers.
Public propertyStatic memberFormatENotationLowerLimit
Gets or sets at what power of ten decimal formatting of numbers switches to E notation for small numbers.
Public propertyStatic memberFormatENotationLowerThreshold
Gets at what actual threshold numeric formatting switches from decimal to E-Notation.
Public propertyStatic memberFormatENotationUpperLimit
Gets or sets at what power of ten decimal formatting of numbers switches to E notation for large numbers.
Public propertyStatic memberFormatENotationUpperThreshold
Gets at what actual threshold numeric formatting switches from decimal to E-Notation.
Public propertyStatic memberFormatMultiplesOfOne
Gets or sets whether floating point numbers close to whole integers should be special cased.
Public propertyStatic memberFormatMultiplesOfPi
Gets or sets whether multiples of 0.5*Pi ought to be special cased.
Public propertyStatic memberInvalidBakeAllow
Gets or sets the default choice for baking invalid objects.
Public propertyStatic memberInvalidBakeAsk
Gets or sets whether a warning ought to be displayed prior to baking invalid geometry. By default this is always TRUE when Grasshopper starts.
Public propertyStatic memberIsTemplateFile
Gets whether a template file has been defined and whether that file ectually exists.
Public propertyStatic memberPanelDefaultFontFamily
Gets or sets the font family name of the default font for panels.
Public propertyStatic memberPanelDefaultFontSize
Gets or sets the font family name of the default font for panels.
Public propertyStatic memberPreviewBumpZBuffer
Gets or sets whether the Document preview bumps the Z-Buffer. Setting this value automatically causes a redraw of the Rhino viewports.
Public propertyStatic memberPreviewGumballs
Gets or sets whether the gumballs will be visible for selected preview geometry.
Public propertyStatic memberPreviewMeshEdges
Gets or sets the Mesh Wire display flag.
Public propertyStatic memberPreviewPlaneRadius
Gets or sets the global Plane radius.
Public propertyStatic memberPreviewPointRadius
Gets the default radius of the point objects given the current style.
Public propertyStatic memberPreviewPointStyle
Gets or sets the point style for Grasshopper preview points.
Public propertyStatic memberPreviewSelectionThickening
Gets or sets the amount of thickening to apply to selected wires.
Public propertyStatic memberPruderyLevel
Gets or sets the Grasshopper UI prudery level.
Public propertyStatic memberRibbonDrawTabIcons
Gets or sets whether tab icons are drawn for the ribbon.
Public propertyStatic memberRibbonSeparators
Gets or sets whether there are separators between different exposures on the component Ribbon.
Public propertyStatic memberRibbonShowObscure
Gets or sets a value indicating whether components marked with DropDown exposure are drawn on the main toolbar anyway.
Public propertyStatic memberRibbonVisible
Gets or sets a value indicating whether components marked with DropDown exposure are drawn on the main toolbar anyway.
Public propertyStatic memberShowTutorials
Gets or sets whether the tutorial browser is shown on Grasshopper load.
Public propertyStatic memberTemplateFile
Gets or sets the template file path. Use String.Empty or Nothing to disable the template file.
Public propertyStatic memberTooltipWiggleRadius
Gets or sets the wiggle radius (in pixels) which the mouse is allowed to move before the tooltip is nuked.
Public propertyStatic memberTrackFileStamps
Public propertyStatic memberTrackPluginLoading
Gets or sets whether plugins are tracked during loading in order to detect plugins causing fatal crashes during load.
Public propertyStatic memberTryDownloadMissingPlugins
Gets or sets whether the 'Unrecognized Objects' dialog pops up on file load.
Top
See Also