Click or drag to resize

GH_Viewport Properties

The GH_Viewport type exposes the following members.

Properties
  NameDescription
Public propertyControlMidPoint
Gets the point in the exact center of the viewport in control coordinates.
Public propertyDiagonal
Gets the length of the diagonal of the viewport in canvas coordinates.
Public propertyHeight
Gets or sets the height of the viewport. Typically this is tied to the dimensions of the canvas. Height is not allowed to go below 5 pixels.
Public propertyMidPoint
Gets or sets the canvas coordinate that is directly underneath the center of the viewport.
Public propertyScreenPort
Gets the dimensions of the viewport in control coordinates.
Public propertySize
Gets or sets the size of the viewport. The size is typically tied to the dimensions of the Canvas.
Public propertyTarget
Gets or sets the location of the target pixel. The target represents where the canvas origin is drawn.
Public propertyTargetRatio
Gets or sets the target ratio with respect to the viewport dimensions. This is a useful tool to prevent weird view changes during a canvas resize.
Public propertyTx
Gets or sets the x-component of the target pixel. The target represents where the canvas origin is drawn.
Public propertyTy
Gets or sets the y-component of the target pixel. The target represents where the canvas origin is drawn.
Public propertyVisibleRegion
Gets the rectangle in canvas coordinates that is visible in the control.
Public propertyWidth
Gets or sets the width of the viewport. Typically this is tied to the dimensions of the canvas. Width is not allowed to go below 5 pixels.
Public propertyZoom
Gets or sets the Zoom factor of the viewport. Please assign only sensible values.
Public propertyZoomBoolean
Sets the zoom of the viewport with a view anchor.
Public propertyZoomInverse
Gets the inverse of the zoom.
Top
See Also