Click or drag to resize

IGH_Structure Properties

The IGH_Structure type exposes the following members.

Properties
  NameDescription
Public propertyBranchGH_Path
Gets a limited access pointer to the data list associated with a certain path.
Public propertyBranchInt32
Gets a limited access pointer to the data list at the specified index.
Public propertyDataCount
Gets the total number of data items stored in all paths.
Public propertyIsEmpty
Gets the Empty state of the structure. If the structure is Empty when it contains no paths and no branches.
Public propertyPath
Gets the data path at the specified index.
Public propertyPathCount
Gets the number of paths defined in this structure.
Public propertyPaths
Gets a list of all the paths in this structure.
Public propertyStructureProxy
Gets a proxy list of all the data-arrays in this structure
Public propertyTopologyDescription
Gets a description of the topology of the structure. Useful for debugging purposes.
Top
See Also