Click or drag to resize

IGH_DocumentObject Properties

The IGH_DocumentObject type exposes the following members.

Properties
  NameDescription
Public propertyAttributes
Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing.
Public propertyComponentGuid
Returns a consistent ID for this object type. Every object must supply a unique and unchanging ID that is used to identify objects of the same type.
Public propertyExposure
Gets the exposure of this object in the Graphical User Interface.
Public propertyIcon_24x24
The icon associated with this object.
Public propertyIcon_24x24_Locked
The greyscale icon of this object.
Public propertyIconDisplayMode
Gets the current display mode of the object.
Public propertyObsolete
Gets whether this object is Obsolete.
Top
See Also