Click or drag to resize

GH_InstanceReference Properties

The GH_InstanceReference type exposes the following members.

Properties
  NameDescription
Public propertyBoundingbox (Overrides GH_GeometricGooTBoundingbox.)
Public propertyClippingBox
Public propertyInstanceDefinition
Public propertyIsGeometryLoaded
Gets the load state of this instance reference object. The instance reference is considered to be loaded when the local instance is not null.
(Overrides GH_GeometricGooTIsGeometryLoaded.)
Public propertyIsReferencedGeometry
Gets a value indicating whether or not this geometry is referenced. Not all IGH_GeometricGoo implementations support referenced geometry.
(Overrides GH_GeometricGooTIsReferencedGeometry.)
Public propertyIsValid
Gets the validity of this instance reference. If the instance reference is referenced but cannot be loaded, the instance reference is not valid.
(Overrides GH_GeometricGooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyModelTransform
Public propertyReferenceID (Overrides GH_GeometricGooTReferenceID.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Top
See Also