Click or drag to resize

GH_Material Properties

The GH_Material type exposes the following members.

Properties
  NameDescription
Public propertyIsValid (Overrides GH_GooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyRdkMaterialId
Gets or sets the RDK material ID this material is associated with.
Public propertyRdkMaterialRmtl
Gets or sets the RDK material RMTL file path.
Public propertyRdkMaterialXml
Gets or sets the RDK material Xml string.
Public propertyType
Gets the implied type based on what fields have been assigned.
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Top
See Also