Click or drag to resize

ID Structure

An ID is used to uniquely identify a specific item.

Namespace:  GH_IO.Serialization
Assembly:  GH_IO (in GH_IO.dll)
Syntax
public struct ID : IComparable<ID>, IEquatable<ID>

The ID type exposes the following members.

Constructors
  NameDescription
Public methodID(String)
Constuctor for IDs.
Public methodID(String, Int32)
Constructor for IDs.
Top
Properties
  NameDescription
Public propertyHash
Gets the hash code.
Public propertyHasIndex
Gets whether the index has been set.
Public propertyHasName
Gets whether the name has been set. Every valid ID must have a name.
Public propertyIndex
Gets the index of this ID, if there is no valid index then -1 is returned.
Public propertyName
Gets the name of this ID.
Top
Methods
See Also