Click or drag to resize

GH_PaletteStyle Class

Contains all the colours for a single capsule palette.
Inheritance Hierarchy
SystemObject
  Grasshopper.GUI.CanvasGH_PaletteStyle

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_PaletteStyle

The GH_PaletteStyle type exposes the following members.

Constructors
  NameDescription
Public methodGH_PaletteStyle(Color)
Construct a new GH_Box_Palette_Colours instance with a single base colour.
Public methodGH_PaletteStyle(Color, Color)
Construct a new GH_Box_Palette_Colours instance.
Public methodGH_PaletteStyle(Color, Color, Color)
Construct a new GH_Box_Palette_Colours instance.
Top
Properties
  NameDescription
Public propertyEdge
Gets or sets the edge of this style.
Public propertyFill
Gets or sets the fill of this style.
Public propertyText
Gets or sets the text of this style.
Top
Methods
  NameDescription
Public methodCreateBrush
Create a fill brush. At low zoom levels the brush will be solid colour, at medium to high zoom levels the brush will have a gradient.
Top
See Also