Click or drag to resize

GH_FadeAnimation Class

Utility class for animating fade ZUI events on the canvas.
Inheritance Hierarchy
SystemObject
  Grasshopper.GUIGH_FadeAnimation

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_FadeAnimation

The GH_FadeAnimation type exposes the following members.

Constructors
  NameDescription
Public methodGH_FadeAnimation
Creates a new instance of the Animator class with default settings.
Public methodGH_FadeAnimation(Single)
Create a new instance of the Animator class with custom values for zoom threshold.
Public methodGH_FadeAnimation(Single, Int32)
Create a new instance of the Animator class with custom values for zoom threshold and duration.
Top
Properties
  NameDescription
Public propertyDuration
Gets or sets the duration (in milliseconds) for ZUI animations. Negative durations are not allowed. The default is 350 milliseconds.
Public propertyFadeAlpha
Gets the blend alpha byte for the current state. 0 means fully hidden, 255 means fully shown.
Public propertyFadeFactor
Gets the blend factor for the current state. 0.0 means fully hidden, 1.0 means fully shown.
Public propertyIsFinished
Gets a value indicating whether this animator has finished animating.
Public propertyPhase
Gets the current animation phase.
Public propertyThreshold
Gets or sets the threshold value for the fade animation trigger.
Public propertyTriggerUpdate
Gets or sets whether this animator triggers canvas updates.
Top
Methods
  NameDescription
Public methodEvaluate(GH_Canvas)
Reevaluate the fade animation parameters. You should call this method from within the Render method of your attributes. If an animation is currently in progress a redraw of the canvas will be scheduled, whether or not the attributes are actually visible on the canvas. You should therefore only call this method if your attributes are already drawing themselves.
Public methodEvaluate(GH_Canvas, Boolean)
Reevaluate the fade animation parameters. You should call this method from within the Render method of your attributes. If an animation is currently in progress a redraw of the canvas will be scheduled, whether or not the attributes are actually visible on the canvas. You should therefore only call this method if your attributes are already drawing themselves.
Public methodEvaluate(GH_Canvas, Single)
Reevaluate the fade animation parameters. You should call this method from within the Render method of your attributes. If an animation is currently in progress a redraw of the canvas will be scheduled, whether or not the attributes are actually visible on the canvas. You should therefore only call this method if your attributes are already drawing themselves.
Public methodEvaluate(GH_Canvas, Single, Boolean)
Reevaluate the fade animation parameters. You should call this method from within the Render method of your attributes. If an animation is currently in progress a redraw of the canvas will be scheduled, whether or not the attributes are actually visible on the canvas. You should therefore only call this method if your attributes are already drawing themselves.
Top
Fields
  NameDescription
Public fieldStatic memberDelay
Gets the number of milliseconds between redraws (25 milliseconds, resulting in ~40 fps)
Top
See Also