Click or drag to resize

GH_MenuTextBox Class

Utility control for putting textboxes into menus.
Inheritance Hierarchy
SystemObject
  Grasshopper.GUIGH_MenuTextBox

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_MenuTextBox

The GH_MenuTextBox type exposes the following members.

Constructors
  NameDescription
Public methodGH_MenuTextBox
Constructor for TextBox collection.
Top
Properties
  NameDescription
Public propertyOriginalText
Gets or sets the original text that was visible when the control was first displayed.
Public propertyText
Gets or sets the current text.
Public propertyTextBoxItem
Gets the text box control embedded in the menu.
Public propertyWidth
Gets or sets the width of the control.
Top
Methods
  NameDescription
Public methodCloseEntireMenuStructure
Call this function to close the ENTIRE menu structure.
Top
Events
  NameDescription
Public eventKeyDown
Raised whenever a key is pressed.
Public eventTextChanged
Raised whenever the text in the textbox changes.
Top
See Also