Click or drag to resize

GH_StandardIcons Class

Provides access to a set of standard icons.
Inheritance Hierarchy
SystemObject
  Grasshopper.GUIGH_StandardIcons

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class GH_StandardIcons

The GH_StandardIcons type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberBlankObjectIcon_24x24
Gets the base icon for objects; an empty white square.
Public propertyStatic memberBlankParameterIcon_24x24
Gets the base icon for parameters; an empty black hexagon.
Public propertyStatic memberClusterIcon_24x24
Gets the icon used for clusters.
Public propertyStatic memberFileIconDll_32x32
Gets the file icon used for Dll files.
Public propertyStatic memberFileIconExe_32x32
Gets the file icon used for Exe files.
Public propertyStatic memberFileIconGH_32x36
Gets the file icon used for Grasshopper Binary files.
Public propertyStatic memberFileIconGha_32x32
Gets the file icon used for Gha files.
Public propertyStatic memberFileIconGHMissing_32x36
Gets the file icon used for missing Grasshopper Binary files.
Public propertyStatic memberFileIconGHX_32x36
Gets the file icon used for Grasshopper Xml files.
Public propertyStatic memberFileIconGHXMissing_32x36
Gets the file icon used for missing Grasshopper Xml files.
Public propertyStatic memberFileIconRhp_32x32
Gets the file icon used for Rhp files.
Public propertyStatic memberFlattenIcon_24x24
Gets the trunk icon used to indicate flattening.
Public propertyStatic memberGraftIcon_24x24
Gets the twig icon used to indicate grafting.
Public propertyStatic memberGroupIcon_24x24
Gets the icon used for canvas groups.
Public propertyStatic memberUnknownObjectIcon_24x24
Gets the icon used for objects that do not have their own icon and unknown objects.
Public propertyStatic memberUserObjectIcon_24x24
Gets the icon used for user objects.
Top
See Also