Click or drag to resize

GH_ExpressionSyntaxWriter Class

Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.ExpressionsGH_ExpressionSyntaxWriter

Namespace:  Grasshopper.Kernel.Expressions
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class GH_ExpressionSyntaxWriter

The GH_ExpressionSyntaxWriter type exposes the following members.

Methods
  NameDescription
Public methodStatic memberRewriteAll
Apply all syntax rulesets to the expression.
Public methodStatic memberRewriteForEvaluator(GH_CodeString)
Rewrite the expression so that all temporary keywords and symbols are replaced by evaluator-specific chars. The expression will become less readable, do not let the user see the result of this function. You need to rewrite the expression with this function if you intend to feed it into the Evaluator.
Public methodStatic memberRewriteForEvaluator(String)
Rewrite the expression so that all temporary keywords and symbols are replaced by evaluator-specific chars. The expression will become less readable, do not let the user see the result of this function. You need to rewrite the expression with this function if you intend to feed it into the Evaluator.
Public methodStatic memberRewriteForGraphicInterface(GH_CodeString)
Rewrite the expression so that tags are replaced by the complex characters that make up the esoteric operators, functions and constants. The expression should become more readable for humans.
Public methodStatic memberRewriteForGraphicInterface(String)
Rewrite the expression so that tags are replaced by the complex characters that make up the esoteric operators, functions and constants. The expression should become more readable
Top
See Also