Click or drag to resize

GH_DocFilePathEventArgs Class

These arguments are passed along with FilePathChanged events on GH_Document.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Grasshopper.KernelGH_DocFilePathEventArgs

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_DocFilePathEventArgs : EventArgs

The GH_DocFilePathEventArgs type exposes the following members.

Constructors
  NameDescription
Public methodGH_DocFilePathEventArgs
Create a new instance of the GH_DocFilePathEventArgs class.
Top
Properties
  NameDescription
Public propertyDocument
Gets the document that raised this event.
Public propertyNewFilePath
Gets the new filepath, the one currently assigned to this document.
Public propertyOldFilePath
Gets the old filepath, prior to the change that triggered this event.
Top
See Also