Click or drag to resize

GH_DocumentTree Class

Represents a hierarchical tree of documents that are subsidiary to one another.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_DocumentTree

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_DocumentTree : IGH_DebugDescription

The GH_DocumentTree type exposes the following members.

Constructors
  NameDescription
Public methodGH_DocumentTree
Create a new document tree.
Top
Properties
  NameDescription
Public propertyFlatCollection
Gets a flat collection of all documents. The most subsidiary documents are at the start of the collection.
Public propertyRoot
Gets the root node for this document.
Public propertyRootDocument
Gets the document inside the root node of this tree.
Top
Methods
  NameDescription
Public methodAppendToDebugLog
Top
See Also