Click or drag to resize

GH_PreviewArgs Class

This class is passed to Objects that implement IGH_PreviewObject during drawing operations.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_PreviewArgs

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_PreviewArgs : IGH_PreviewArgs

The GH_PreviewArgs type exposes the following members.

Properties
  NameDescription
Public propertyDefaultCurveThickness
Gets the curve thickness as defined by the viewport display scheme.
Public propertyDisplay
Gets the Pipeline that is being used to draw the current preview.
Public propertyDocument
Gets the Grasshopper document that is currently drawing the preview.
Public propertyMeshingParameters
Gets the meshing parameters to be used during meshing breps.
Public propertyShadeMaterial
Gets the document default material for unselected Faces.
Public propertyShadeMaterial_Selected
Gets the document default material for selected Faces.
Public propertyViewport
Gets the Viewport in which the current preview is drawn.
Public propertyWireColour
Gets the document default colour for unselected Wires.
Public propertyWireColour_Selected
Gets the document default colour for selected Wires.
Top
See Also