Click or drag to resize

GH_PreviewMeshArgs Class

This class is passed to objects that implement IGH_PreviewData during mesh drawing operations.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_PreviewMeshArgs

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_PreviewMeshArgs

The GH_PreviewMeshArgs type exposes the following members.

Constructors
  NameDescription
Public methodGH_PreviewMeshArgs
Initializes a new instance of the GH_PreviewMeshArgs class
Top
Properties
  NameDescription
Public propertyMaterial
Gets the material in which meshes ought to be drawn.
Public propertyMeshingParameters
Gets the meshing parameters which ought to be used for meshing breps and surfaces. If this property returns a null reference, meshes are supposed to be omitted.
Public propertyPipeline
Gets the Display Pipeline we're currently drawing with.
Public propertyViewport
Gets the Viewport in which we're currently drawing.
Top
See Also