Click or drag to resize

GH_PreviewWireArgs Class

This class is passed to objects that implement IGH_PreviewData during wire drawing operations.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_PreviewWireArgs

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_PreviewWireArgs

The GH_PreviewWireArgs type exposes the following members.

Constructors
  NameDescription
Public methodGH_PreviewWireArgs
Initializes a new instance of the GH_PreviewWireArgs class
Top
Properties
  NameDescription
Public propertyColor
Gets the color in which wires ought to be drawn.
Public propertyPipeline
Gets the Display Pipeline we're currently drawing with.
Public propertyThickness
Gets the thickness in which wires ought to be drawn.
Public propertyViewport
Gets the Viewport in which we're currently drawing.
Top
See Also