Click or drag to resize

IGH_ContextualParameter Interface

Base interface for contextual parameters. This makes accessing non-strongly-typed functionality easier.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_ContextualParameter

The IGH_ContextualParameter type exposes the following members.

Properties
  NameDescription
Public propertyAtLeast
Minimum number of inputs to request
Public propertyAtMost
Maximum number of inputs to request.
Public propertyContextualData
Iterate over all specified contextual values.
Public propertyImmediate
Gets whether this parameter triggers immediate updates from inside its getter. Immediacy is important for a smooth experience, but it maybe disabled if the expected recalculation time becomes excessive.
Public propertyPrompt
Gets the prompt to be displayed while asking the user to enter data. The prompt string may contain '{0}' fields which will be populated with the amount of values picked so far.
Top
Methods
  NameDescription
Public methodAssignContextualData
Assign a collection of values as contextual data.
Public methodAutoAssignContextualData
Use the in-build getter UI to assign data to the parameter.
Top
See Also