Click or drag to resize

IGH_ObjectProxy Interface

Provides proxy data for all Grasshopper components and parameters.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_ObjectProxy

The IGH_ObjectProxy type exposes the following members.

Properties
  NameDescription
Public propertyDesc
Gets the Instance Description associated with this proxy.
Public propertyExposure
Gets or sets the Exposure of the target object. Only set the exposure if you know what you are doing.
Public propertyGuid
Gets the Guid of the target object. In the case of Compiled Objects, the Guid represents the ComponentID, in the case of User Objects, the Guid is a hash of the file path.
Public propertyIcon
Gets the icon for this object.
Public propertyKind
Gets the kind of the Proxy target object.
Public propertyLibraryGuid
Gets the ID of the library (GHA file) that defines this object.
Public propertyLocation
Gets the location of the target object. If the proxy represents a Compiled Object, the location refers to the file path of the assembly, in the case of User Objects, the location refers to the object file.
Public propertyObsolete
Gets whether this proxy represents an obsolete object.
Public propertySDKCompliant
Gets whether this object is compliant with the current Rhino version.
Public propertyType
Gets the Type for the target object. If the proxy references a User Object, the Type member will be null.
Top
Methods
  NameDescription
Public methodCreateInstance
Create a new instance from the target object.
Public methodDuplicateProxy
Create a duplicate of this proxy.
Top
See Also